1

Closed

SPDevExplorer web service on server is out of sync...

description

Thanks for the great tool; unfortunately it doesn't work on my machine. The PC has Visual Studio 2008 and MOSS 2007 on Windows 2008; I'd like to connect to it via remote desktop and use SPDevExplorer there to edit SharePoint's sites.
Installation goes ok and I'm able to run Sharepoint Explorer in my Visual Studio, but when I'm trying to connect to the local sharepoint server I get this error:
 
"The SPDevExplorer web service on server is out of sync with the required web service version 2.2. Please (re)install the SPDevExplorer.solution.WSP package version 2.2 or higher on server".
 
I've tried uninstalling and running the previous version instead (the 2.3; according to: http://spdevexplorer.codeplex.com/WorkItem/View.aspx?WorkItemId=7799 it's actually the 2.2), but still without any success.

file attachments

Closed Nov 16, 2009 at 1:02 AM by svdoever

comments

svanschalkwyk wrote Sep 1, 2009 at 6:23 PM

Any developments on this? I'm getting the same thing.

svanschalkwyk wrote Sep 1, 2009 at 9:30 PM

Change all occurrences of "2.2" in source to "2.4". Change Web Reference for SPDevExplorerWebService to somewhere on your machine. Add quotation marks to Build Event macros if you have spaces in your directory names.
Build and deploy. works great.
Finally a tool I can use - dump SharePoint Designer in the bin where it belongs.
Thanks!

svanschalkwyk wrote Sep 2, 2009 at 4:40 AM

Fixed files

wrote Sep 2, 2009 at 4:41 AM

arangas wrote Sep 10, 2009 at 4:33 PM

I had this same problem but couldn't reproduce it after restarting my machine.

wrote Nov 16, 2009 at 12:56 AM

Wrong error is given on 401 error. Change into new message, so "service version wrong" is not displayed.

wrote Nov 16, 2009 at 12:58 AM

Changed message.

wrote Nov 16, 2009 at 1:02 AM

Resolved with changeset 46470.

wrote Feb 13, 2013 at 11:58 PM

wrote May 16, 2013 at 6:28 AM